Clinet portal outage
Incident Report for DigitalFyre
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Nov 20, 2016 - 11:48 EST
Investigating
We are investigating the root cause behind the client portal outage.

Note: This outage does not affect customers' services.
Posted Nov 20, 2016 - 11:30 EST