Customer Portal Outage
Incident Report for DigitalFyre
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 23:30 EST
Investigating
We are investigating an issue that is affecting the client portal. We apologize for the inconvenience.
Posted Nov 05, 2020 - 12:51 EST
This incident affected: Corporate Websites (Client Portal).